الانتقال إلى المحتوى

عند نداء تقرير من خلال شاشة (Form) تظهر لى رسالة ا


Tim

Recommended Posts

السلام عليكم ورحمة الله

اخى الكريم .... هل تستخدم ريبورت 9i
اذا كان كذلك يمكن استخدام show_web_document
إذا ظهرت نفس الرسالة فيكون هناك مشكلة فعلا فى الريبورت سيرفر

رابط هذا التعليق
شارك

السلام عليكم ورحمة الله وبركاته
اود ان اعرض عليك البنامج الذى كتبته

repid := FIND_REPORT_OBJECT('R1');
v_rep:= RUN_REPORT_OBJECT(repid,plid);
rep_status := REPORT_OBJECT_STATUS(v_rep);
WHILE rep_status in ('RUNNING','OPENING_REPORT','ENQUEUED') LOOP
rep_status := report_object_status(v_rep);

END LOOP;

IF rep_status = 'FINISHED' THEN

--Display report in the browser

WEB.SHOW_DOCUMENT('http://tim-ju:8888/reports/rwservlet/getjobid'||

substr(v_rep,instr(v_rep,'_',-1)+1)||'?'||'server=repserver90','_blank');

ELSE

message('Error when running report');

END IF;

المشكلة هو ان المتغير v_rep ياخذ قيمة فارغة Null علما ان
R1 is an Opject in the form navigator who is linked with my report file

ارجو المساعده وجزاك الله خيرا

علما انى استخدم Report 9i

رابط هذا التعليق
شارك

انضم إلى المناقشة

يمكنك المشاركة الآن والتسجيل لاحقاً. إذا كان لديك حساب, سجل دخولك الآن لتقوم بالمشاركة من خلال حسابك.

زائر
أضف رد على هذا الموضوع...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   تمت استعادة المحتوى السابق الخاص بك.   مسح المحرر

×   You cannot paste images directly. Upload or insert images from URL.

جاري التحميل
×
×
  • أضف...

برجاء الإنتباه

بإستخدامك للموقع فأنت تتعهد بالموافقة على هذه البنود: سياسة الخصوصية